Payments Stuck in BTM Module

Resolved

Dear Customer,

We have been monitoring the situation and the system is stable now.
Posted Feb 14, 2025 - 15:36 UTC

Monitoring

Dear Customer,

All stuck payments have been processed successfully. We are monitoring the situation.
Posted Feb 14, 2025 - 09:14 UTC

Update

Dear Customer,

The investigation continues with highest priority.
Posted Feb 14, 2025 - 08:50 UTC

Investigating

Dear Customer,

We are currently experiencing issues while processing payments out of the BTM Module. This is being investigated with highest priority.
Posted Feb 14, 2025 - 06:48 UTC
This incident affected: TIS Livesystem.