TIS - Issues with Payment Processing

Resolved

Dear Customer,

The incident has been resolved.
Posted Jun 18, 2026 - 15:15 UTC

Monitoring

Dear Customer,

A fix has been implemented and we are monitoring the system performance.
Posted Jun 18, 2026 - 14:37 UTC

Investigating

Dear Customer,

We are currently experiencing issues with Payment Processing. This is being investigated with highest priority.
Posted Jun 18, 2026 - 14:22 UTC
This incident affected: TIS Livesystem.