Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 09, 2024 - 16:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Jun 10, 2024 - 12:25 UTC
Update
Dear Customers,
we are planning maintenance work on our cloud infrastructure and are improving the TIS platform. We expect several service interruptions during the announced maintenance window, the TIS platform will not be usable during the maintenance work.
We apologize for any inconvenience this may cause.
Posted Jul 09, 2024 - 16:00 UTC
Scheduled
Dear Customers,
we are improving the TIS platform. You might experience small interruptions during the rollout. In such cases, please refresh your browser window.
We apologize for any inconvenience this may cause.
Posted Dec 05, 2023 - 13:54 UTC
This scheduled maintenance affected: TIS Livesystem.