Issues with services using FX rates

Resolved

Dear TIS Customer,

We've been monitoring the system and it has been stable. Issue has been resolved.
Posted Jun 10, 2025 - 13:03 UTC

Monitoring

Dear TIS Customer,

The connection has been restored. FX rates will be fetched and refreshed in a few minutes.

We will continue to monitor the system.
Posted Jun 10, 2025 - 10:04 UTC

Identified

Dear TIS Customer,

We are currently experiencing issues with our FX provider. This might lead to service interruptions.

We're investigating with highest priority and will update you shortly.
Posted Jun 10, 2025 - 07:06 UTC
This incident affected: TIS Livesystem.